Forum

Du musst dich anmelden um Beiträge und Themen zu erstellen.

Ender-3 Mod

Seiten:Erste«1314151617
Zitat von MagicBugsBunny am 12.06.2018, 16:26 Uhr

...Ich helfe gerne bei gezielten Fragen weiter 🙂

Aber pauschale Beschreibungen oder so, da bin ich nicht der richtige dafür 🙁
Und für's flashen gibt es echt genug Anleitungen im Netz und traut euch, es geht nichts kaputt dabei 🙂

Danke für das Hilfsangebot! Ich sehe nur Albträume! Löten und Flashen gehören nicht zu den Dingen mit denen ich mich beschäftige und überlasse das gern denen die sich damit auskennen. Schon die Drähte für den LED-Streifen sind eine Herausforderung für mich. Zunächst ist der Draht angelötet und die LEDs leuchten aber spätestens nach der Montage ist der Draht wieder ab. Schrauben ist doch eine viel bessere Befestigungsmethode 😉

kann keinen Lötkolben halten
Es gibt ja Leute, die so Zeug zusammenbraten, wo es richtig, also so richtig doof wäre, wenn sich unterwegs ne kalte Lötstelle herausstellen würde. Die haben das mal zusammengeschrieben:
🙂
Ender2 mit Gehäuse; X5S-Mechanik mit MKS SBase-Board/Smoothieware, E3d V6/Titan, 240V-Heatbed

Hallo zusammen,

hmm, wo fange ich jetzt am besten an?

@Uwe R.
Wollte dir bestimmt nicht zu nahe treten, sorry.
Wissenslücken habe ich auch reichlich, aber ich bin bemüht, diese etwas zu verkleinern, wenn es mir gelingt.
Bevor ich Unfug produziere, versuche ich mich meist vorher ins Thema einzulesen und zu informieren. Ja, wie man sieht, das gelingt nicht immer. Liegt diesmal sicher auch am Umfang und der Komplexität des Themas.

Leider kann ich jetzt nicht ins Elbtal umziehen, aber wir können versuchen, uns über diese Plattform auszutauschen, so gut es geht und es die freie Zeit erlaubt. Das Thema ist interessant, die Leute sind nett und hilfsbereit.

In PrusaControl hatte ich schon kurz reingeschaut. So wie das für mich ausschaut, wird das mit dem "Verschwindezaubersich nicht so einfach lösen lassen.

Auszug aus dem prusacontrol.log:

TypeError: list indices must be integers or slices, not str

[ERROR][main.py:95:log_exception()]-Logging an uncaught exception
Traceback (most recent call last):
File "sceneRender.py", line 487, in paintGL
KeyError: 'Ender-3'

[ERROR][main.py:95:log_exception()]-Logging an uncaught exception
Traceback (most recent call last):
File "sceneRender.py", line 487, in paintGL
KeyError: 'Ender-3'

[ERROR][main.py:95:log_exception()]-Logging an uncaught exception
Traceback (most recent call last):
File "sceneRender.py", line 487, in paintGL
KeyError: 'Ender-3'

. . .

Habe von Programmierung aber keine Ahnung. Leider liegt auch mein Fokus im Moment mehr auf den Hardware Mods und den Firmware Geschichten.

 

@MagicBugsBunny

Klasse, sogar mit Bild! Danke. Das hilft einmal weiter.
Nett, Stiftleiste ausgelötet und CAT Netzwerk Patchkabel direkt angelötet. So hatte ich mir das auch vorgestellt.
Danke, gezielt fragen werde ich, wenn ich darf, sobald mir mehr klar ist, was da genau abläuft.

Aber pauschale Beschreibungen oder so, da bin ich nicht der richtige dafür

Kein Problem. Hoffe, du bist mir nicht böse, war nun schon etwas frustriert, der erfolglosen Suche wegen und des wochenlangen Lesen ohne nennenswerten Erfolg. Passiert mir eher selten. Meist habe ich nach ein paar Wochen, zumindest eine ungefähre Vorstellung, wie die Zusammenhänge sind.

Und für's flashen gibt es echt genug Anleitungen im Netz und traut euch, es geht nichts kaputt dabei 

Naja, das könnte ich jetzt nicht so behaupten. Und um die Einstellung Uwe etwas zu untermauern, es gibt so ein paar Dinge, die man beachten muss.

An den Fuse- und Lock-Bits der Atmel Microcontroller sollte man tunlichst vermeiden herumzuspielen.
Anschauen und notieren ja, wenn da was beim setzen schief läuft, wird es richtig schwierig. Da geht im schlimmsten Fall nur noch auslöten und ein HVSP Fusebit Programmer, war die meisten vor ein riesiges Problem stellen dürfte. Da dürfte ich bei einigen Arduino Nanos schon einschlägige Erfahrungen sammeln. Klar, bei drei Euro Stückpreis in China kein großer Verlust.

Das Ender-3 Melzi Board habe ich beim herumspielen und dumpen des Flashinhaltes durch eine Unachtsamkeit direkt einmal "dumm" gemacht. Danach startete es nicht mehr ...
So ein ISP Programmer und avrdude sind halt kein Spielzeug.

War jetzt nicht das riesige Problem, da ich mir vorher die  Ender-3 Firmware Hex-Files von Creality zusammen gesucht und herunter geladen hatte. Nach dem erneuten flashen über die ISP Schnittstelle läuft es wieder.
Wenn Interesse und erlaubt, kann ich diese euch hochladen.
Ein gewisses Restrisiko bleibt aber immer bei den binären Hex-Files, weil man nie genau wissen kann, was da enthalten ist und ob sie überhaupt funktionieren. Ist halt (noch) kein Quellcode verfügbar.

Ohne diese wäre ich jetzt auch zwangsweise auf Marlin. Aber bevor ich diesen Schritt freiwillig gehen, würde ich halt gerne vorher schon genauer verstehen, was da so abgeht. Wenn dann nachher was schief läuft, kann man sich zumindest selbst etwas weiter helfen und selbst eingebaute Fehler suchen.

 

@Uwe R.

Wären Steckverbinder zum crimpen oder in Schneidklemmtechnik nicht ein gangbarer Weg um der Lötallergie zu entgehen? 😉
Wobei ich persönlich mehr darauf tippe, es liegt bei dir eher am verwendeten Material und Werkzeug, und weniger am manuellen Geschick.

 

 

zweiter Treffer bei Google …. http://www.chaos-drucker.de/anleitungen-und-tutorials/creality-ender3-mit-marlin-ausstatten/

 

 

Zitat von x-cube am 12.06.2018, 19:42 Uhr

 

Und für's flashen gibt es echt genug Anleitungen im Netz und traut euch, es geht nichts kaputt dabei 

Naja, das könnte ich jetzt nicht so behaupten. Und um die Einstellung Uwe etwas zu untermauern, es gibt so ein paar Dinge, die man beachten muss.

An den Fuse- und Lock-Bits der Atmel Microcontroller sollte man tunlichst vermeiden herumzuspielen.
Anschauen und notieren ja, wenn da was beim setzen schief läuft, wird es richtig schwierig. Da geht im schlimmsten Fall nur noch auslöten und ein HVSP Fusebit Programmer, war die meisten vor ein riesiges Problem stellen dürfte. Da dürfte ich bei einigen Arduino Nanos schon einschlägige Erfahrungen sammeln. Klar, bei drei Euro Stückpreis in China kein großer Verlust.

 

Um Gottes Willen … mit sowas kommt man in unserer 3D Drucker Welt überhaupt nicht in Berührung!
Ich will ja nur einen Arduino Bootloader flashen.

Ach ist sehr lieb von Euch! Lesen bildet! Da ich in meiner Schulzeit und im Anschluß bis einschließlich Studium nur Russisch als Fremdsprache hatte würde ich die russische Version des Dokuments vorziehen wenn schon nicht in deutsch 😉 Mein Englisch hab ich in verschiedenen portugiesischen Kneipen von einem Engländer gelernt. Spätestens nach dem 3. Portwein und 2 Flaschen Vino Verde war die Aufnahmefähigkeit stark eingeschränkt!

Bis vor kurzem hatte ich nur einen großen dicken Lötkolben mit dem ich als Bub zum Muttertag Holzbrettchen und Kochlöffel für meine liebe Mutter verziert habe. Damals war es noch üblich, Kabelenden zu verzinnen. Dafür ist der noch geeignet aber nicht für Elektronik. Da Lidl die grad im Angebot hatte hab ich mir vor wenigen Wochen einen mit Akku gekauft. Ich war selber erstaunt! Es ist mir gelungen, am Raspi-Zero die Kontaktleiste sauber anzulöten und hab mich schon gefühlt wie der Meister der Lötkolben. Leider läßt sich wohl nicht alles so einfach löten! Die Kontaktpins der LED-Streifen sahen zunächst nicht so kompliziert aus und der Draht hat gehalten bis zum Einbau in die Halterung. Leider läßt sich das nicht krimpen. Meine Kenntnisse im Hartlöten lassen sich leider hier nicht anwenden. Und auch sonst komm ich mit meinen Kenntnissen aus Hydraulik und Pneumatik bei elektronischen Schaltkreisen nicht sehr weit.

Zum Flashen gibt es in der Tat schon viele Abhandlungen im Netz! Währen diese nicht im Fachchinesisch und würden die sich nicht oft auch noch widersprechen hätte ich möglicher Weise auch eine Chance. Allerdings ist das nur die halbe Miete. Zuvor muß die Firmware noch angepaßt werden um diese Fähigkeit auch sinnvoll zu nutzen. Wenn Ihr da bereits etwas im Netz gefunden habt ist das schon mal ein Anfang und ich stelle es gern in den Download. Mit etwas Glück wird noch etwas daraus.

Wie bereits erwähnt hab ich den Zonestar hervor geholt. Wenn der dabei auf der Strecke bleibt ist das nicht so schlimm.

Danke für den Versuch mit "Ender-3Control"! Ich versteh es auch nicht! Eigentlich macht Prusa nichts anderes als ich. Ein 3D-Modell im stl oder obj Format mit einem Bild oben und unten zu rendern. Programmierung ist das nicht. Also hab ich die prusai3_platform.stl mit PrintBed03.png von oben und PrintBed03_GRID.png von unten beklebt. Von unten ist das Ergebnis Top! Von oben der "Verschwindezauber". Wende ich die Bilder auf PrintBed03.obj an funktioniert es. Also hatte ich das stl-Format im Verdacht und habe PrintBed04.obj erstellt. Ergebnis wie bei prusai3_platform.stl oder E3_heatbed.stl. Ich hab keine Erklärung dafür.

Morgen hat mein CAD-Händler zur Vorstellung der 2019er Versionen von Autodesk in die Brauerei nach Köstritz geladen. Mal sehen ob ich es wieder nach Hause schaffe und es was zu berichten gibt.

kann keinen Lötkolben halten
Zitat von Uwe R. am 12.06.2018, 20:35 Uhr

Spätestens nach dem 3. Portwein und 2 Flaschen Vino Verde war die Aufnahmefähigkeit stark eingeschränkt!

Alkohol ist wichtig, denn Alkohol konserviert 😀

 

 

Kurz gefragt:

Für den CR-10 gibt es ja den Mod der doppelten Z-Achse mit zusätzlichem Stepper. Würde der Ender 3 auch davon profitieren oder ist der dafür zu klein?

Ja! Ist ja auch was hängen geblieben! 😉

Wenn Du danach fragst ob der Ender 3 auch davon profitiert muß zuvor geklärt werden, ob der CR-10 davon profitiert. Mit ja oder nein ist das nach meiner Meinung nicht beantwortet. Meinen CR-10 hab ich nicht aufgerüstet und der druckt noch immer zuverlässig und gut. Im Netz sind einige gar der Meinung, Die Führung am Ender-3 auf der 2.Seite währe zu viel und würde sich negativ auf den Druck auswirken. Am Ender-2 haben wir nur den einen Arm und auch das funktioniert. Wofür ist dann also der 2.Antrieb oder die 2.Führung gut? Ich persönlich halte den Ender-3 für zu groß die Abstützung wie am Ender-2 weglassen zu können. Der CR-10 kommt im Auslieferzustand auch ohne 2. Spindel aus. Wer den CR-10 mit zusätzlichem Extruder und schwererem Hotend betreiben möchte braucht die 2.Spindel. Am Ender-3 könnte es noch mit einer Spindel funktionieren. Nachteile hat die 2.Spindel schließlich auch. Wenn mal die Stepper nicht synchron laufen muß das wieder ausgerichtet werden. Der CR-10 macht das nicht selbständig. Eine Möglichkeit währen noch 2 Spindeln mit einem Antrieb. Im Moment sitzt auch das Netzteil der 2.Spindel im Weg. Möglicher Weise hat Creality3d deshalb den CR20 mit dem Netzteil im Unterbau versehen und es kommen noch Versionen mit 2.Spindel und zusätzlichem Extruder. Der CR-X mit doppeltem Extruder ist ja schon gezeigt worden.

kann keinen Lötkolben halten

Irgend wer hatte da ein Problem mit dem Z-Endstopp! Hab auf thingiverse etwas entdeckt. Ender 3 XZ housing + Endstop by GlowingEmbers sieht gut aus!

kann keinen Lötkolben halten

Mein CR-10 hat eine zweite Z Spindel die ich per Riemen gekoppelt habe. Am Druckbild hat sich aber nichts verbessert.
Eine zweite Z Spindel die nicht referenziert ist auch total gefährlich.
Deshalb nur mechanisch gekoppelt oder wirklich einzel gesteuert mit Endschalter und nicht einfach in Reihe oder Parallel geschaltet.

Ich denke auch, das benötigt man nur wenn das Hotend schwerer wird oder man z.B. rechts auch einen Extruder montieren möchte.

Mein Ender3 nervt mich grad, oder besser gesagt das E3D V6 Hotend …. Filament klemmt im All Metall Throat beim Reatract 🙁

Oder kann man das erst ab 250Grad benützen?

Seiten:Erste«1314151617