Forum

Du musst dich anmelden um Beiträge und Themen zu erstellen.

Anycubic 4Max - mein Neuester

Seiten:Erste«1819202122»Letzte

Ich habe mal ein neues Thema zum 4Max eröffnet, um es hiervon zu trennen

Anycubic 4Max und Precision Piezo (Auto Bed Leveling)

 

Zitat von Stephan am 11.06.2018, 08:10 Uhr

Sehr gut geworden die Anleitung. Ich freu mich auf den Nachbau. Du könntest n der Teileliste eventuell noch angeben, ob 12V oder 24V bei Lüftern und e3d Hotends.

Genau solche Anregungen will ich, um aus der Beta bald eine Release machen zu können, Danke!

PS: 12 Volt.

Über Lego, Fischertechnik, C64, Amiga, Mac, Palm, iPhone, iPad, Arduino, Raspberry Pi zu 3D-Druckern.

@altfrank,

 

ich wollte gerade die Marlin 1.1.8 mit deiner configuration.h, configurationadv.h language.h compilieren allergings wirf die arduino software dabei den Fehler #error "Unknown MOTHERBOARD value set in Configuration.h"

 

mache ich etwas falsch? kann ich alternativ auch einfach die HEX aus deiner Firmware flashen?

noch eine Frage: ich abe 2208 Stepper verbaut und daher die Anschlus kabel auf dem Mainboard um 180° gedreht. muss ich das jetzt mit dem neuen Pancake stepper von E3D rückgängig machen?

 

schonmal danke für die Hilfe!

@kugelfang: Genau deswegen habe ich die Hex mit reingepackt. X und Y sind schon in der Firmware gedreht für die neuen Treiber. Z nicht, weil ich den nicht getauscht habe.

Bei den E3D Steppern musst Du am Stepper die zwei inneren Pins vertauschen.

Zu Firmware und Elektronik werde ich morgen noch mehr schreiben.

Über Lego, Fischertechnik, C64, Amiga, Mac, Palm, iPhone, iPad, Arduino, Raspberry Pi zu 3D-Druckern.

prima, danke, werde mal gucken ob ich das hin bekomme,

hast du ggf auch eine idee wieso ich die FW nicht selber kompiliert bekomme?

 

EDIT:

kann es sein dass du in der zip die board.h mit der definition für das TRIGORILLA_13 vergessen hast?

 

EDIT 2:

ich habe deine in der zip enthaltene HEX gflascht. darin scheinen die Lüfter (Hotend/Bauteil) vertauscht zu sein

So, hardware Umbau ist abgeschlossen. jetzt benötige nur noch hilfe die Firmware selber zu kompilieren damit die Motoren bei mir nicht falsch rum laufen

Es kann sein, daß die Lüfter jetzt gegenüber der Original-Frimware vertauscht sind, aber nur so lassen sie sich korrekt ansteuern. Habe ich weiter oben schon geschrieben.

Das TRIGORILLA_13 ist in der boards.h der 1.1.x bugfix drin, die ich am 31.05.2018 heruntergeladen habe. Von wann ist Deine?

PS: Habe gerade eben die aktuelle Bugfix heruntergeladen, lässt sich problemlos mit meinen drei Dateien kompilieren.

https://github.com/MarlinFirmware/Marlin/tree/bugfix-1.1.x

Über Lego, Fischertechnik, C64, Amiga, Mac, Palm, iPhone, iPad, Arduino, Raspberry Pi zu 3D-Druckern.

hmm ich habe gerade eben nochmal die 1.1.x frisch runtergeladen und entpackt. Dann die 3 dateien aus deiner zip rein kopiert und mit arduino 1.8.5 die Marlin.ino geöffnet. wenn ich jetzt auf sketch --> Binärdatei kompilieren und exportieren gehe wirft er wieder einen fehler, diesmal aber einen neuen:

Arduino: 1.8.5 (Windows 10), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

Build-Optionen wurden verändert, alles wird neu kompiliert
In file included from sketch\ultralcd.cpp:96:0:

sketch\ultralcd_impl_DOGM.h:46:20: fatal error: U8glib.h: No such file or directory

#include <U8glib.h>

^

compilation terminated.

exit status 1
Fehler beim Kompilieren für das Board Arduino/Genuino Mega or Mega 2560.

 

was mache ich falsch?

 

EDIT: Lösung gefunden:

Do this:

  • Sketch > Include Library > Manage libraries
  • Wait for download to finish
  • In the "Filter your search" box, type "u8glib".
  • Scroll down until you see "U8glib by oliver". Click on it.
  • Click "Install"
  • Wait for installation to finish
  • Click "Close"

 

EDIT2: So hat funktioniert! Herzlichen Dank. Werde alles morgen / übermorgen testen und berichten!

@alfrank:

hmm ich habe die Lüfter jetzt umgesteckt jedoch läuft der Extruder Lüfter nicht von wie von dir beschireben an wenn ich den Drucker anschalte. muss nicht ggf

#define E0_AUTO_FAN_PIN -1 auf #define E0_AUTO_FAN_PIN 9 geändert werden??

Der Bauteillüfter läst ich übrigens steuern, klackert aber bei geschiwndigkeiten <100% merkwürdig

Welche Bauformen bzw. Typen von Lüftern hast Du genommen?

Der originale 40 mm Extruderlüfter des 4Max läuft schwer an, ich habe daher alle Lüfter ersetzt.

Hast Du ein Multimeter, um zu messen, ob an den Zuleitungen Spannung ankommt?

Oder einfach mal diverse Lüfter gegeneinander tauschen.

Bei mir funktionieren alle Lüfter mit den geposteten Dateien.

PS: Ich habe so viele Änderungen hin und her gemacht, daß ich nicht mehr unbedingt alle Schritte vom Auslieferungszustand aus 100% nachvollziehen kann.

Über Lego, Fischertechnik, C64, Amiga, Mac, Palm, iPhone, iPad, Arduino, Raspberry Pi zu 3D-Druckern.
Seiten:Erste«1819202122»Letzte