Forum

Du musst dich anmelden um Beiträge und Themen zu erstellen.

Anycubic I3 Mega verbindet nicht mit Repetier Server über PI

Ich habe gestern erneut versucht den Rasperry PI mit Repetier Server mit dem I3 Mega zu verbinden. Geht nicht.

Nachdem ich letzte Woche einen alten PI mit Repetier Server reaktivieren wollte und das nicht funktionierte, habe ich einen neuen PI angeschafft.

Der kam gestern und ich hatte das gleich Problem. Er baut keine Verbindung mit demen I3 Mega auf. Viel kann man ja da nicht einstellen. Firmware, Port und Baudrate. Er tut aber nix.

Hat jemand ne Idee und/oder den I3 Mega schon erfogreich verbunden?

Ich hoffe morgen kommt der Tevo Tornado. Dann versucht ich das mit dem gleich auch mal. Nach dem ersten Druck 😉 .

Gruß in die Runde,

Stefan

Moin Stefan,

der Mega hängt bei mir relativ Problemlos am Repetier Server, hier die Port Einstellung:

PS: Repetier legt mir neue Drucker immer als Firmware Repetier an, wenn ich nicht jedesmal nochmal in die KOnfig gehe und auf Marlin umstelle, klappt nix.

Hochgeladene Dateien:
  • usb_port_i3_mega_repetier_server.png
Ich liebe Fertigdrucker, weil: ...ich kauf mir auch kein Akkuschrauberbausatz.

Da bei mir gerade der eben im anderen Post beschriebene Druck läuft, möchte ich ungern mit dem PI spielen. Ich habe irgenwo gelesen, dass nach der Verbindung der Drucker neu gestartet wird. Ist das immer so?

Aber nun zu deinen Daten. Ich meine mich erinnern zu können, das der Port anders lautete, die restlichen Daten sind gleich. Auf die richtige Firmware, Marlin, habe ich geachtet. Ich hatte andere Konfigurationen ausgetestet. Kein Erfolg.

Gut möglich dass da mit dem neuen Board auch der USB Controller anders ist.. wenns der einzige Drucke am Pi ist, musste mans eigentlich erkennen. Erkennt Windows den Drucker?

Und ja, eine Neuverbindung / Reset am Pi resettet sehr oft auch die angeschlossenen Drucker..

Ich liebe Fertigdrucker, weil: ...ich kauf mir auch kein Akkuschrauberbausatz.

Windows erkennt den Drucker. Ich kann ihn mit S3D und Cura ansprechen. Mite dem Pi konnte ich gestern nicht testen. Der Druck lief zu lange und heute schaue ich erst mal nach dem Bett.

Steck den Drucker vom Pi ab. Dann verbinde dich per SSH auf das Pi. Dann gibst du dort ls /dev/tty.* ein, da kommt dein so eine list mit einigen Einträgen. Dann steckt den Drucker an. Und den gleichen Befehl noch aml rennen lassen. Wenn das Linux auf dem Pi was mit dem Device anfangen kann und den Seriellen USB Port erkennt, dann steht in der Liste ein neuer Eintrag, das ist der Port den Du verwenden musst.

 

Sollte das nicht gehen drucker noch mal ab- und anstecken, gibt sudo dmesg ein und poste bitte die ca. letzten 15 Zeilen. Fall es installiert ist auch der Output von lsusb interessant.

 

Es kann sein, das Dein Board einen "exotischen" usb chip verwendet, denn das Linux nicht erkennt.

 

PS: Der Reset ist bei Arduinos normal. Sie werden, sobald die serielle Verbindung aufgebaut wird, resetet damit sie durch den Bootloader neue Firmware laden können.

@Hendrik:

dank für die Info. Kann leider gerade nicht an den Drucker. Der ist nach der Hotbed-Reparatur wieder voll im Produktionsstress. Muss bis zum Wochenende den "Little Stik" fertig haben. Sonst gibts Ärger mit meine Vater ;-). Der wartet sehnsüchtig drauf.

Zurück zu deiner Arbeitsanweisung. Ich bin absoluter Pi- und Linux-Laie. Ich muss erst mal rausfinden was SSH ist. Ich krieg das aber schon hin. Der Mensch ist ja lernfähig. Meistens jedenfalls.

16.02. Update:

Immer noch keine Gelegenheit gehabt den Pi zu testen. Produktion gerade fertig geworden. Morgen wird der Flieger abgeliefert und montiert.

Dann kann ich nach dem Pi schauen. Melde mich.